Signup form errors
Incident Report for Nimbox
Resolved
We have pushed a fix for this issue.
Posted Jan 19, 2017 - 20:41 GMT
Investigating
Right now you're unable to create a trial account using our homepage. We're working on fixing this.
Posted Jan 18, 2017 - 11:27 GMT