Web Preview not responding
Incident Report for Nimbox
Resolved
We've fixed this issue, and you can now view your documents online. Yay!
Posted Jul 18, 2017 - 21:37 BST
Investigating
We're currently working on an issue with our Web Preview feature, preventing files from being displayed. We'll provide updates as soon as we can!
Posted Jul 18, 2017 - 14:43 BST