Support ticketing not available
Incident Report for Nimbox
Resolved
This incident has been resolved.
Posted Jul 18, 2017 - 21:37 BST
Investigating
Our support desk provider is currently having issues, and we cannot access support tickets. Until they're back online, you can tweet us at: @NimboxSupport
Posted Jul 18, 2017 - 15:36 BST