Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2025 - 17:30 GMT
Scheduled
We have been busy in our lab here at Nimbox, and now we have some new changes to make to our production systems to keep them healthy and secure.
The changes will be made between 17:30 and 20:00 on Wednesday the 12th of March. We'll carry out the work pretty quickly, but the system will be unavailable during these times.
Posted Mar 06, 2025 - 15:21 GMT
This scheduled maintenance affected: π» Web App, π Web Editing, π₯ Desktop Apps, π± Mobile Apps, and π Homepage & Resource Sites.